<!DOCTYPE html><html lang="en" prefix="og: http://ogp.me/ns#"><head><meta charset="UTF-8"><meta http-equiv="X-UA-Compatible" content="IE=edge"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="https://gmpg.org/xfn/11" /><link rel="shortcut icon" href="https://www.somalilandpress.com/wp-content/uploads/2018/04/icons-4.png" type="image/x-icon" /><link rel="apple-touch-icon" sizes="180x180" href="https://www.somalilandpress.com/wp-content/uploads/2018/04/icons-4.png"><link rel="alternate" type="application/rss+xml" title="Somalilandpress.com RSS Feed" href="https://www.somalilandpress.com/feed/" /><link rel="alternate" type="application/atom+xml" title="Somalilandpress.com Atom Feed" href="https://www.somalilandpress.com/feed/atom/" /><link rel="pingback" href="https://www.somalilandpress.com/xmlrpc.php" /> <!--[if lt IE 9]> <script src="https://www.somalilandpress.com/wp-content/themes/soledad/js/html5.js"></script> <![endif]--><style type="text/css" media="all">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</style><title>Somaliland:President Announces University Graduates Will Go On National Service Duties in 2019 - Somalilandpress.com</title><link rel="canonical" href="https://www.somalilandpress.com/somalilandpresident-announces-university-graduates-will-go-on-national-service-duties-in-2019/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Somaliland:President Announces University Graduates Will Go On National Service Duties in 2019 - Somalilandpress.com" /><meta property="og:description" content="His Excellency the President of the Republic of Somaliland, Musa Bihi Abdi, announced that&hellip;" /><meta property="og:url" content="https://www.somalilandpress.com/somalilandpresident-announces-university-graduates-will-go-on-national-service-duties-in-2019/" /><meta property="og:site_name" content="Somalilandpress.com" /><meta property="article:section" content="Somaliland" /><meta property="article:published_time" content="2018-08-29T10:21:09+00:00" /><meta property="og:image" content="https://www.somalilandpress.com/wp-content/uploads/2018/08/IMG_3076.jpg" /><meta property="og:image:secure_url" content="https://www.somalilandpress.com/wp-content/uploads/2018/08/IMG_3076.jpg" /><meta property="og:image:width" content="800" /><meta property="og:image:height" content="554" /><meta name="twitter:card" content="summary" /><meta name="twitter:description" content="His Excellency the President of the Republic of Somaliland, Musa Bihi Abdi, announced that&hellip;" /><meta name="twitter:title" content="Somaliland:President Announces University Graduates Will Go On National Service Duties in 2019 - Somalilandpress.com" /><meta name="twitter:image" content="https://www.somalilandpress.com/wp-content/uploads/2018/08/IMG_3076.jpg" /> <script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"https:\/\/www.somalilandpress.com\/","sameAs":[],"@id":"https:\/\/www.somalilandpress.com\/#organization","name":"Somalilandpress","logo":"https:\/\/www.somalilandpress.com\/wp-content\/uploads\/2018\/04\/RLogo-3-new.png"}</script> <link rel="amphtml" href="https://www.somalilandpress.com/somalilandpresident-announces-university-graduates-will-go-on-national-service-duties-in-2019/amp/" /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Somalilandpress.com &raquo; Feed" href="https://www.somalilandpress.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Somalilandpress.com &raquo; Comments Feed" href="https://www.somalilandpress.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Somalilandpress.com &raquo; Somaliland:President Announces University Graduates Will Go On National Service Duties in 2019 Comments Feed" href="https://www.somalilandpress.com/somalilandpresident-announces-university-graduates-will-go-on-national-service-duties-in-2019/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.somalilandpress.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);</script> <link rel='stylesheet' id='penci-fonts-css'  href='//fonts.googleapis.com/css?family=PT+Serif%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CPlayfair+Display+SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7COpen+Sans%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%26subset%3Dcyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;ver=1.0' type='text/css' media='all' /> <script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://www.somalilandpress.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script> <link rel='https://api.w.org/' href='https://www.somalilandpress.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.somalilandpress.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.somalilandpress.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 4.9.8" /><link rel='shortlink' href='https://www.somalilandpress.com/?p=87069' /><link rel="alternate" type="application/json+oembed" href="https://www.somalilandpress.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.somalilandpress.com%2Fsomalilandpresident-announces-university-graduates-will-go-on-national-service-duties-in-2019%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.somalilandpress.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.somalilandpress.com%2Fsomalilandpresident-announces-university-graduates-will-go-on-national-service-duties-in-2019%2F&#038;format=xml" /> <script type="text/javascript" src="httpss://www.somalilandpress.com/wp-content/plugins/audio-player/assets/audio-player.js?ver=2.0.4.6"></script> <script type="text/javascript">AudioPlayer.setup("httpss://www.somalilandpress.com/wp-content/plugins/audio-player/assets/player.swf?ver=2.0.4.6", {width:"300",animation:"yes",encode:"yes",initialvolume:"60",remaining:"yes",noinfo:"no",buffer:"5",checkpolicy:"no",rtl:"no",bg:"5c0707",text:"000000",leftbg:"ad0c0c",lefticon:"f7a90d",volslider:"44f022",voltrack:"e3f5df",rightbg:"8c0d0d",rightbghover:"b0a311",righticon:"b7eb0c",righticonhover:"c2b30f",track:"fafa9e",loader:"fac967",border:"f0c239",tracker:"700e0b",skip:"edab71",pagebg:"FFFFFF",transparentpagebg:"yes"});</script>  <noscript><div style="position:fixed; top:0px; left:0px; z-index:3000; height:100%; width:100%; background-color:#FFFFFF"><div style="font-family: Trebuchet MS; font-size: 14px; background-color:#FFF000; padding: 10pt;">Oops! It appears that you have disabled your Javascript. In order for you to see this page as it is meant to appear, we ask that you please re-enable your Javascript!</div></div> </noscript> <script type="text/javascript">function disableSelection(e){if(typeof e.onselectstart!="undefined")e.onselectstart=function(){return false};else if(typeof e.style.MozUserSelect!="undefined")e.style.MozUserSelect="none";else e.onmousedown=function(){return false};e.style.cursor="default"}window.onload=function(){disableSelection(document.body)}</script> <script type="text/javascript">document.oncontextmenu=function(e){var t=e||window.event;var n=t.target||t.srcElement;if(n.nodeName!="A")return false};
document.ondragstart=function(){return false};</script> <script type="text/javascript">window.addEventListener("keydown",function(e){if(e.ctrlKey&&(e.which==65||e.which==66||e.which==67||e.which==70||e.which==73||e.which==80||e.which==83||e.which==85||e.which==86)){e.preventDefault()}});document.keypress=function(e){if(e.ctrlKey&&(e.which==65||e.which==66||e.which==70||e.which==67||e.which==73||e.which==80||e.which==83||e.which==85||e.which==86)){}return false}
/**
 * For mac we need to check metakey
 */
window.addEventListener("keydown",function(e){if( event.metaKey&&(e.which==65||e.which==66||e.which==67||e.which==70||e.which==73||e.which==80||e.which==83||e.which==85||e.which==86)){e.preventDefault()}});document.keypress=function(e){if(e.ctrlKey&&(e.which==65||e.which==66||e.which==70||e.which==67||e.which==73||e.which==80||e.which==83||e.which==85||e.which==86)){}return false}</script> <script type="text/javascript">document.onkeydown=function(e){e=e||window.event;if(e.keyCode==123||e.keyCode==18){return false}}</script> <style type="text/css">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</style><meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/> <!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://www.somalilandpress.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><noscript><style type="text/css">.wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head><body data-rsssl=1 class="post-template-default single single-post postid-87069 single-format-standard wpb-js-composer js-comp-ver-5.0.1 vc_responsive"> <a id="close-sidebar-nav" class="header-3"><i class="fa fa-close"></i></a><nav id="sidebar-nav" class="header-3"><div id="sidebar-nav-logo"> <a href="https://www.somalilandpress.com/"><img class="penci-lazy" src="https://www.somalilandpress.com/wp-content/themes/soledad/images/penci-holder.png" data-src="https://www.somalilandpress.com/wp-content/uploads/2018/04/somalilandpress.png" alt="Somalilandpress.com" /></a></div><ul id="menu-main-menu" class="menu"><li id="menu-item-85011" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-85011"><a href="https://www.somalilandpress.com/">Home</a></li><li id="menu-item-20251" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-20251"><a href="https://www.somalilandpress.com/pages/somaliland/">Somaliland</a></li><li id="menu-item-77821" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-77821"><a href="https://www.somalilandpress.com/pages/world/">World</a><ul class="sub-menu"><li id="menu-item-77809" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77809"><a href="https://www.somalilandpress.com/pages/somalia/">Somalia</a></li><li id="menu-item-20253" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20253"><a href="https://www.somalilandpress.com/pages/africa/">Africa</a></li><li id="menu-item-77807" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77807"><a href="https://www.somalilandpress.com/pages/ethiopia/">Ethiopia</a></li><li id="menu-item-77976" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77976"><a href="https://www.somalilandpress.com/pages/djibouti/">Djibouti</a></li></ul></li><li id="menu-item-77808" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77808"><a href="https://www.somalilandpress.com/pages/opinion/">Opinion</a></li><li id="menu-item-77806" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77806"><a target="_blank" href="https://www.somalilandpress.com/pages/editorial/">Editorial</a></li><li id="menu-item-77805" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77805"><a href="https://www.somalilandpress.com/pages/business/">Business</a></li><li id="menu-item-56102" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56102"><a href="https://www.somalilandpress.com/pages/videos/">Videos</a></li></ul></nav><div class="wrapper-boxed header-style-header-3 dark-layout-enabled"><div class="penci-top-bar topbar-menu"><div class="container"><div class="penci-headline"><ul id="menu-top-menu" class="penci-topbar-menu"><li id="menu-item-80372" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80372"><a href="https://www.somalilandpress.com/contactcenter/">Contact</a></li><li id="menu-item-80373" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-80373"><a>Contact: somalilandpress@gmail.com</a></li></ul><div class="penci-topbar-social"><div class="inner-header-social"> <a href="https://www.facebook.com/somalilandmedia/" target="_blank"><i class="fa fa-facebook"></i></a> <a href="https://twitter.com/somalilandpress" target="_blank"><i class="fa fa-twitter"></i></a></div></div></div></div></div><header id="header" class="header-header-3 has-bottom-line"><div class="inner-header"><div class="container align-left-logo has-banner"><div id="logo"><h2> <a href="https://www.somalilandpress.com/"><img src="https://www.somalilandpress.com/wp-content/uploads/2018/04/somalilandpress.png" alt="Somalilandpress.com" /></a></h2></div><div class="header-banner header-style-3"> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle"
 style="display:inline-block;width:728px;height:90px"
 data-ad-client="ca-pub-8106074610781145"
 data-ad-slot="3830485601"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div></div><nav id="navigation" class="header-layout-bottom menu-style-1 header-3 menu-item-padding"><div class="container"><div class="button-menu-mobile header-3"><i class="fa fa-bars"></i></div><ul id="menu-main-menu-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-85011"><a href="https://www.somalilandpress.com/">Home</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-20251"><a href="https://www.somalilandpress.com/pages/somaliland/">Somaliland</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-77821"><a href="https://www.somalilandpress.com/pages/world/">World</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77809"><a href="https://www.somalilandpress.com/pages/somalia/">Somalia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20253"><a href="https://www.somalilandpress.com/pages/africa/">Africa</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77807"><a href="https://www.somalilandpress.com/pages/ethiopia/">Ethiopia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77976"><a href="https://www.somalilandpress.com/pages/djibouti/">Djibouti</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77808"><a href="https://www.somalilandpress.com/pages/opinion/">Opinion</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77806"><a target="_blank" href="https://www.somalilandpress.com/pages/editorial/">Editorial</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77805"><a href="https://www.somalilandpress.com/pages/business/">Business</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56102"><a href="https://www.somalilandpress.com/pages/videos/">Videos</a></li></ul><div id="top-search"> <a class="search-click"><i class="fa fa-search"></i></a><div class="show-search"><form role="search" method="get" id="searchform" action="https://www.somalilandpress.com/"><div> <input type="text" class="search-input" placeholder="Type and hit enter..." name="s" id="s" /></div></form> <a class="search-click close-search"><i class="fa fa-close"></i></a></div></div></div></nav></header><div class="container penci-breadcrumb single-breadcrumb"> <span><a class="crumb" href="https://www.somalilandpress.com/">Home</a></span><i class="fa fa-angle-right"></i> <span><a class="crumb" href="https://www.somalilandpress.com/pages/somaliland/">Somaliland</a></span><i class="fa fa-angle-right"></i> <span>Somaliland:President Announces University Graduates Will Go On National Service Duties in 2019</span></div><div class="container container-single container-single-magazine penci_sidebar right-sidebar penci-enable-lightbox"><div id="main" class="penci-main-sticky-sidebar"><div class="theiaStickySidebar"><article id="post-87069" class="post-87069 post type-post status-publish format-standard has-post-thumbnail hentry category-somaliland"><div class="header-standard header-classic single-header"><div class="penci-standard-cat"><span class="cat"><a class="penci-cat-name" href="https://www.somalilandpress.com/pages/somaliland/">Somaliland</a></span></div><h1 class="post-title single-post-title">Somaliland:President Announces University Graduates Will Go On National Service Duties in 2019</h1><div class="post-box-meta-single"> <span class="author-post"><span>written by <a class="author-url" href="https://www.somalilandpress.com/author/mgoth/">MGoth</a></span></span> <span>August 29, 2018</span></div></div><div class="post-image"> <a href="https://www.somalilandpress.com/wp-content/uploads/2018/08/IMG_3076.jpg" data-rel="penci-gallery-image-content"> <img class="attachment-penci-full-thumb size-penci-full-thumb penci-lazy wp-post-image" src="https://www.somalilandpress.com/wp-content/themes/soledad/images/penci2-holder.png" alt="Somaliland:President Announces University Graduates Will Go On National Service Duties in 2019" data-src="https://www.somalilandpress.com/wp-content/uploads/2018/08/IMG_3076.jpg"> </a></div><div class="post-entry blockquote-style-2"><div class="inner-post-entry"><p>His Excellency the President of the Republic of Somaliland, Musa Bihi Abdi, announced that fresh graduates from universities will be put on national service duties beginning from January 2019.</p><p>President Bihi, speaking at a graduation ceremony which the University of Hargeisa held for 937 students, yesterday, Tuesday, revealed that the state had prepared the necessary funds for the exercise.</p><p>&#8220;We have checked 10 billion Somaliland Shillings, equivalent to about US$ 1 million into the National Service account my government initiated,&#8221; he revealed.</p><p>The president said the minor technicalities pertaining to the proper execution of the activities are now being attended to.</p><p>&#8220;We are putting the last touches to the plan. Come January 2019, the scheme will go off on full throttle,&#8221; he said.</p><p>President stated that NS activity will start off on a pilot number of 1500 graduates.</p><p>&#8220;Out of this number, 500 will be girls. We will train both male and female members of the scheme not on their respective disciplines but on how to maximize their skills and future employment engagements honing their resilience and creativity,&#8221; he stated.</p><p>The President said the boys will be trained at boarding facilities outside cities but that the girls will undergo same training at hometowns.</p><p>The introduction of national service figured high on the President&#8217;s manifesto when he was running for the presidency late last year.</p><div class="hatom-extra" style="display:none !important;visibility:hidden;"><span class="entry-title">Somaliland:President Announces University Graduates Will Go On National Service Duties in 2019</span> was last modified: <span class="updated"> August 29th, 2018</span> by <span class="author vcard"><span class="fn">MGoth</span></span></div><div class="penci-single-link-pages"></div></div></div><div class="tags-share-box center-box"> <span class="single-comment-o"><i class="fa fa-comment-o"></i>0 comment</span><div class="post-share"> <span class="count-number-like">0</span><a class="penci-post-like single-like-button" data-post_id="87069" title="Like" data-like="Like" data-unlike="Unlike"><i class="fa fa-heart-o"></i></a><div class="list-posts-share"> <a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https://www.somalilandpress.com/somalilandpresident-announces-university-graduates-will-go-on-national-service-duties-in-2019/"><i class="fa fa-facebook"></i><span class="dt-share">Facebook</span></a> <a target="_blank" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20Somaliland:President%20Announces%20University%20Graduates%20Will%20Go%20On%20National%20Service%20Duties%20in%202019%20-%20https://www.somalilandpress.com/somalilandpresident-announces-university-graduates-will-go-on-national-service-duties-in-2019/"><i class="fa fa-twitter"></i><span class="dt-share">Twitter</span></a> <a target="_blank" href="https://plus.google.com/share?url=https://www.somalilandpress.com/somalilandpresident-announces-university-graduates-will-go-on-national-service-duties-in-2019/"><i class="fa fa-google-plus"></i><span class="dt-share">Google +</span></a> <a data-pin-do="none" target="_blank" href="https://pinterest.com/pin/create/button/?url=https://www.somalilandpress.com/somalilandpresident-announces-university-graduates-will-go-on-national-service-duties-in-2019/&#038;media=https://www.somalilandpress.com/wp-content/uploads/2018/08/IMG_3076.jpg&#038;description=Somaliland:President%20Announces%20University%20Graduates%20Will%20Go%20On%20National%20Service%20Duties%20in%202019"><i class="fa fa-pinterest"></i><span class="dt-share">Pinterest</span></a></div></div></div><div class="post-author"><div class="author-img"> <img alt='' src='https://secure.gravatar.com/avatar/a4a9ecc474254f6e4deca155e506f1f1?s=100&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/a4a9ecc474254f6e4deca155e506f1f1?s=200&#038;d=retro&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' /></div><div class="author-content"><h5><a href="https://www.somalilandpress.com/author/mgoth/" title="Posts by MGoth" rel="author">MGoth</a></h5><p></p></div></div><div class="post-pagination"><div class="prev-post"><div class="prev-post-inner"><div class="prev-post-title"> <span>previous post</span></div> <a href="https://www.somalilandpress.com/ethiopiaabdi-illey-taken-to-prison-in-the-capital-addis-ababa/"><div class="pagi-text"><h5 class="prev-title">Ethiopia:Abdi Illey taken to prison in the capital Addis Ababa</h5></div> </a></div></div></div><div class="post-related"><div class="post-title-box"><h4 class="post-box-title">Related Articles</h4></div><div class="penci-owl-carousel penci-owl-carousel-slider penci-related-carousel" data-lazy="true" data-item="3" data-desktop="3" data-tablet="2" data-tabsmall="2" data-auto="false" data-speed="300" data-dots="true"><div class="item-related"> <a class="related-thumb penci-image-holder owl-lazy" data-src="https://www.somalilandpress.com/wp-content/uploads/2018/04/Muse.jpg" href="https://www.somalilandpress.com/ap-interview-somaliland-president-defends-uae-military-deal/" title="AP Interview: Somaliland president defends UAE military deal"> </a><h3><a href="https://www.somalilandpress.com/ap-interview-somaliland-president-defends-uae-military-deal/">AP Interview: Somaliland president defends UAE military deal</a></h3> <span class="date">April 3, 2018</span></div><div class="item-related"> <a class="related-thumb penci-image-holder owl-lazy" data-src="https://www.somalilandpress.com/wp-content/uploads/2016/06/Somaliland-Football-Team.jpg" href="https://www.somalilandpress.com/somalilandthese-two-african-football-teams-just-competed-world-cup-unrecognized-countries/" title="Somaliland:These Two African Football Teams Just Competed in the World Cup for Unrecognized Countries"> </a><h3><a href="https://www.somalilandpress.com/somalilandthese-two-african-football-teams-just-competed-world-cup-unrecognized-countries/">Somaliland:These Two African Football Teams Just Competed in...</a></h3> <span class="date">June 9, 2016</span></div><div class="item-related"> <a class="related-thumb penci-image-holder owl-lazy" data-src="https://www.somalilandpress.com/wp-content/uploads/2018/06/Safaarada-Jabuuti-310x193.jpg" href="https://www.somalilandpress.com/djibouti-embassy-start-registering-pensioners-living-in-somaliland/" title="Djibouti Embassy start registering pensioners living in Somaliland"> </a><h3><a href="https://www.somalilandpress.com/djibouti-embassy-start-registering-pensioners-living-in-somaliland/">Djibouti Embassy start registering pensioners living in Somaliland</a></h3> <span class="date">June 23, 2018</span></div><div class="item-related"> <a class="related-thumb penci-image-holder owl-lazy" data-src="https://www.somalilandpress.com/wp-content/uploads/2016/08/13925151_1091976170876915_6841996711391419748_n.jpg" href="https://www.somalilandpress.com/somalilandthe-3rd-annual-diaspora-conference-kick-offs/" title="Somaliland:The 3rd Annual Diaspora Conference kick-offs"> </a><h3><a href="https://www.somalilandpress.com/somalilandthe-3rd-annual-diaspora-conference-kick-offs/">Somaliland:The 3rd Annual Diaspora Conference kick-offs</a></h3> <span class="date">August 2, 2016</span></div><div class="item-related"> <a class="related-thumb penci-image-holder owl-lazy" data-src="https://www.somalilandpress.com/wp-content/uploads/2018/02/d4.png" href="https://www.somalilandpress.com/an-investment-guide-to-ethiopia-at-a-glance/" title="An Investment Guide to Ethiopia At a Glance"> </a><h3><a href="https://www.somalilandpress.com/an-investment-guide-to-ethiopia-at-a-glance/">An Investment Guide to Ethiopia At a Glance</a></h3> <span class="date">February 4, 2018</span></div><div class="item-related"> <a class="related-thumb penci-image-holder owl-lazy" data-src="https://www.somalilandpress.com/wp-content/uploads/2016/06/SHIIL.png" href="https://www.somalilandpress.com/somalilanddahabshil-group-donates-cash-support-east-africa-university-buhodle-campus/" title="Somaliland:Dahabshil Group Donates Cash in Support of East Africa University Buhodle Campus"> </a><h3><a href="https://www.somalilandpress.com/somalilanddahabshil-group-donates-cash-support-east-africa-university-buhodle-campus/">Somaliland:Dahabshil Group Donates Cash in Support of East...</a></h3> <span class="date">June 30, 2016</span></div><div class="item-related"> <a class="related-thumb penci-image-holder owl-lazy" data-src="https://www.somalilandpress.com/wp-content/uploads/2014/10/cirro12.jpg" href="https://www.somalilandpress.com/waddani-party-irans-axis-somaliland/" title="WADDANI PARTY: IRAN’S AXIS IN SOMALILAND"> </a><h3><a href="https://www.somalilandpress.com/waddani-party-irans-axis-somaliland/">WADDANI PARTY: IRAN’S AXIS IN SOMALILAND</a></h3> <span class="date">March 27, 2017</span></div><div class="item-related"> <a class="related-thumb penci-image-holder owl-lazy" data-src="https://www.somalilandpress.com/wp-content/uploads/2018/06/cabient-585x390.jpg" href="https://www.somalilandpress.com/somalilandcabinet-approves-amended-presidential-and-local-councils-elections-and-voters-registration-law/" title="Somaliland:Cabinet approves Amended Presidential and Local Councils Elections and voters registration Law"> </a><h3><a href="https://www.somalilandpress.com/somalilandcabinet-approves-amended-presidential-and-local-councils-elections-and-voters-registration-law/">Somaliland:Cabinet approves Amended Presidential and Local Councils Elections...</a></h3> <span class="date">June 8, 2018</span></div><div class="item-related"> <a class="related-thumb penci-image-holder owl-lazy" data-src="https://www.somalilandpress.com/wp-content/uploads/2017/04/logo111.jpg" href="https://www.somalilandpress.com/somalilandpresidential-condolences-to-london-terror-attack-victims/" title="Somaliland:Presidential Condolences to London Terror Attack Victims"> </a><h3><a href="https://www.somalilandpress.com/somalilandpresidential-condolences-to-london-terror-attack-victims/">Somaliland:Presidential Condolences to London Terror Attack Victims</a></h3> <span class="date">June 5, 2017</span></div><div class="item-related"> <a class="related-thumb penci-image-holder owl-lazy" data-src="https://www.somalilandpress.com/wp-content/uploads/2016/05/image-1709.jpeg" href="https://www.somalilandpress.com/somaliland-sl-diaspora-sweden-holds-demonstration-outside-swedish-parliament/" title="Somaliland: SL Diaspora in Sweden holds a demonstration Outside the  Swedish Parliament"> </a><h3><a href="https://www.somalilandpress.com/somaliland-sl-diaspora-sweden-holds-demonstration-outside-swedish-parliament/">Somaliland: SL Diaspora in Sweden holds a demonstration...</a></h3> <span class="date">May 21, 2016</span></div></div></div><div class="post-comments no-comment-yet" id="comments"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title"><span>Leave a Comment</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/somalilandpresident-announces-university-graduates-will-go-on-national-service-duties-in-2019/#respond" style="display:none;">Cancel Reply</a></small></h3><form action="https://www.somalilandpress.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-form-comment"><textarea id="comment" name="comment" cols="45" rows="8" placeholder="Your Comment" aria-required="true"></textarea></p><p class="comment-form-author"><input x-autocompletetype="name-full" id="author" name="author" type="text" value="" placeholder="Name*" size="30" aria-required='true' /></p><p class="comment-form-email"><input x-autocompletetype="email" id="email" name="email" type="text" value="" placeholder="Email*" size="30" aria-required='true' /></p><p class="comment-form-url"><input id="url" name="url" type="text" value="" placeholder="Website" size="30" /></p><p><input type='text' value='VuuKIzy84tB5' onclick='this.select()' size='20' /> <b>* Copy This Password *</b></p><p><input type='text' name='passthis' id='passthis' value='' size='20' /> <b>* Type Or Paste Password Here *</b></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit" /> <input type='hidden' name='comment_post_ID' value='87069' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p></form></div></div></article></div></div><div id="sidebar" class="penci-sidebar-content style-5 pcalign-left penci-sticky-sidebar"><div class="theiaStickySidebar"><aside id="text-7" class="widget widget_text"><div class="textwidget"><p><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br /> <ins class="adsbygoogle"
 style="display:inline-block;width:336px;height:280px"
 data-ad-client="ca-pub-8106074610781145"
 data-ad-slot="9318260781"></ins><br /> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></p></div></aside><aside id="penci_popular_news_widget-1" class="widget penci_popular_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Popular Posts</span></h4><ul class="side-newsfeed display-order-numbers"><li class="penci-feed featured-news"> <span class="order-border-number"> <span class="number-post">1</span> </span><div class="side-item"><div class="side-image"> <a class="penci-image-holder penci-lazy" rel="bookmark" data-src="https://www.somalilandpress.com/wp-content/uploads/2018/04/IMG_FBB847-B89C51-462610-BF8B57-F145D0-F54E2A.jpeg" href="https://www.somalilandpress.com/somalilandcentral-bank-issues-ultimatum-to-all-private-financial-institutions/" title="Somaliland:Central Bank Issues ultimatum to all Private Financial Institutions"></a></div><div class="side-item-text"><h4 class="side-title-post"><a href="https://www.somalilandpress.com/somalilandcentral-bank-issues-ultimatum-to-all-private-financial-institutions/" rel="bookmark" title="Somaliland:Central Bank Issues ultimatum to all Private Financial Institutions">Somaliland:Central Bank Issues ultimatum to all Private Financial Institutions</a></h4> <span class="side-item-meta">April 16, 2018</span></div></div></li><li class="penci-feed"> <span class="order-border-number"> <span class="number-post">2</span> </span><div class="side-item"><div class="side-image"> <a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.somalilandpress.com/wp-content/uploads/2018/04/somaliland-commonwealth-chogm-900x600-263x175.jpg" href="https://www.somalilandpress.com/somalilandwhy-we-should-be-at-the-commonwealth-summit/" title="Somaliland:Why we should be at the Commonwealth summit"></a></div><div class="side-item-text"><h4 class="side-title-post"><a href="https://www.somalilandpress.com/somalilandwhy-we-should-be-at-the-commonwealth-summit/" rel="bookmark" title="Somaliland:Why we should be at the Commonwealth summit">Somaliland:Why we should be at the Commonwealth summit</a></h4> <span class="side-item-meta">April 16, 2018</span></div></div></li><li class="penci-feed"> <span class="order-border-number"> <span class="number-post">3</span> </span><div class="side-item"><div class="side-image"> <a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.somalilandpress.com/wp-content/uploads/2018/04/15214511549131.jpg" href="https://www.somalilandpress.com/rebirth-of-somalilandthe-demise-of-the-greater-somalia-concept-and-somali-unity-notion-one-of-somalias-obsessions-part-21/" title="Rebirth of Somaliland;The demise of the Greater Somalia concept and Somali unity notion: One of Somalia’s obsessions -PART 21"></a></div><div class="side-item-text"><h4 class="side-title-post"><a href="https://www.somalilandpress.com/rebirth-of-somalilandthe-demise-of-the-greater-somalia-concept-and-somali-unity-notion-one-of-somalias-obsessions-part-21/" rel="bookmark" title="Rebirth of Somaliland;The demise of the Greater Somalia concept and Somali unity notion: One of Somalia’s obsessions -PART 21">Rebirth of Somaliland;The demise of the Greater Somalia concept and Somali unity notion: One of Somalia’s obsessions -PART 21</a></h4> <span class="side-item-meta">April 10, 2018</span></div></div></li><li class="penci-feed"> <span class="order-border-number"> <span class="number-post">4</span> </span><div class="side-item"><div class="side-image"> <a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.somalilandpress.com/wp-content/uploads/2016/10/image-20160927-14625-1cozt97.jpg" href="https://www.somalilandpress.com/africa-demand-next-united-nations-secretary-general/" title="What Africa should demand from the next United Nations secretary general"></a></div><div class="side-item-text"><h4 class="side-title-post"><a href="https://www.somalilandpress.com/africa-demand-next-united-nations-secretary-general/" rel="bookmark" title="What Africa should demand from the next United Nations secretary general">What Africa should demand from the next United Nations secretary general</a></h4> <span class="side-item-meta">October 3, 2016</span></div></div></li><li class="penci-feed"> <span class="order-border-number"> <span class="number-post">5</span> </span><div class="side-item"><div class="side-image"> <a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.somalilandpress.com/wp-content/uploads/2016/06/Ethio-Som-murder-300x169.jpg" href="https://www.somalilandpress.com/ethiopiathe-mad-mullah-21st-century-abdi-mohamed-omar-somali-regional-state-president/" title="Ethiopia:The mad mullah of 21st century, Abdi Mohamed Omar, Somali Regional State President"></a></div><div class="side-item-text"><h4 class="side-title-post"><a href="https://www.somalilandpress.com/ethiopiathe-mad-mullah-21st-century-abdi-mohamed-omar-somali-regional-state-president/" rel="bookmark" title="Ethiopia:The mad mullah of 21st century, Abdi Mohamed Omar, Somali Regional State President">Ethiopia:The mad mullah of 21st century, Abdi Mohamed Omar, Somali Regional State President</a></h4> <span class="side-item-meta">June 8, 2016</span></div></div></li></ul></aside><aside id="text-3" class="widget widget_text"><div class="textwidget"><p><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br /> <br /> <ins class="adsbygoogle" style="display: block;" data-ad-client="ca-pub-8106074610781145" data-ad-slot="4443368314" data-ad-format="auto"></ins><br /> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></p></div></aside><aside id="penci_latest_news_widget-1" class="widget penci_latest_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Opinion</span></h4><ul class="side-newsfeed penci-feed-2columns penci-2columns-feed"><li class="penci-feed"><div class="side-item"><div class="side-image"> <a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.somalilandpress.com/wp-content/uploads/2018/08/2-263x175.jpeg" href="https://www.somalilandpress.com/jama-mohamed-ismail-the-peacemaker-of-somaliland/" title="Jama Mohamed Ismail: The Peacemaker of Somaliland"></a></div><div class="side-item-text"><h4 class="side-title-post"><a href="https://www.somalilandpress.com/jama-mohamed-ismail-the-peacemaker-of-somaliland/" rel="bookmark" title="Jama Mohamed Ismail: The Peacemaker of Somaliland">Jama Mohamed Ismail: The Peacemaker of Somaliland</a></h4></div></div></li><li class="penci-feed"><div class="side-item"><div class="side-image"> <a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.somalilandpress.com/wp-content/uploads/2018/08/Elders-meeting-Somalia-263x175.jpg" href="https://www.somalilandpress.com/somalilandtraditional-leaders-have-become-greedy-mushroomed-exponentially-and-lost-their-traditional-role/" title="Somaliland:Traditional Leaders have Become Greedy, Mushroomed Exponentially and Lost their Traditional Role"></a></div><div class="side-item-text"><h4 class="side-title-post"><a href="https://www.somalilandpress.com/somalilandtraditional-leaders-have-become-greedy-mushroomed-exponentially-and-lost-their-traditional-role/" rel="bookmark" title="Somaliland:Traditional Leaders have Become Greedy, Mushroomed Exponentially and Lost their Traditional Role">Somaliland:Traditional Leaders have Become Greedy, Mushroomed Exponentially and Lost their Traditional Role</a></h4></div></div></li><li class="penci-feed"><div class="side-item"><div class="side-image"> <a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.somalilandpress.com/wp-content/uploads/2017/05/image.jpg" href="https://www.somalilandpress.com/somaliland-accessibility-inaccessibility-of-water-in-hargeisa/" title="Somaliland: Accessibility of Water in Hargeisa"></a></div><div class="side-item-text"><h4 class="side-title-post"><a href="https://www.somalilandpress.com/somaliland-accessibility-inaccessibility-of-water-in-hargeisa/" rel="bookmark" title="Somaliland: Accessibility of Water in Hargeisa">Somaliland: Accessibility of Water in Hargeisa</a></h4></div></div></li><li class="penci-feed"><div class="side-item"><div class="side-image"> <a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.somalilandpress.com/wp-content/uploads/2018/07/image-220x175.png" href="https://www.somalilandpress.com/the-wind-of-change-sweeping-the-greater-horn-of-africa-region-has-propelled-prime-minister-ahmed-abiy-to-the-helm-of-ethiopia/" title="The Wind of Change Sweeping the Greater Horn of Africa Region Has Propelled Prime Minister Ahmed Abiy to the Helm of Ethiopia"></a></div><div class="side-item-text"><h4 class="side-title-post"><a href="https://www.somalilandpress.com/the-wind-of-change-sweeping-the-greater-horn-of-africa-region-has-propelled-prime-minister-ahmed-abiy-to-the-helm-of-ethiopia/" rel="bookmark" title="The Wind of Change Sweeping the Greater Horn of Africa Region Has Propelled Prime Minister Ahmed Abiy to the Helm of Ethiopia">The Wind of Change Sweeping the Greater Horn of Africa Region Has Propelled Prime Minister Ahmed Abiy to the Helm of Ethiopia</a></h4></div></div></li><li class="penci-feed"><div class="side-item"><div class="side-image"> <a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.somalilandpress.com/wp-content/uploads/2018/08/e3624579-dbf8-49c7-a7fd-c22b04e86717-263x175.jpg" href="https://www.somalilandpress.com/bashir-goth-as-somaliland-ambassador/" title="Bashir Goth as Somaliland Ambassador???"></a></div><div class="side-item-text"><h4 class="side-title-post"><a href="https://www.somalilandpress.com/bashir-goth-as-somaliland-ambassador/" rel="bookmark" title="Bashir Goth as Somaliland Ambassador???">Bashir Goth as Somaliland Ambassador???</a></h4></div></div></li><li class="penci-feed"><div class="side-item"><div class="side-image"> <a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.somalilandpress.com/wp-content/uploads/2018/08/Bashir-Goth-263x175.png" href="https://www.somalilandpress.com/guban-view-blatant-somalia-apologist-bashir-goth-wrong-choice-for-somalilands-representative-in-washington-dc/" title="Guban View: Blatant Somalia apologist, Bashir Goth, wrong choice for Somaliland&#8217;s representative in Washington DC"></a></div><div class="side-item-text"><h4 class="side-title-post"><a href="https://www.somalilandpress.com/guban-view-blatant-somalia-apologist-bashir-goth-wrong-choice-for-somalilands-representative-in-washington-dc/" rel="bookmark" title="Guban View: Blatant Somalia apologist, Bashir Goth, wrong choice for Somaliland&#8217;s representative in Washington DC">Guban View: Blatant Somalia apologist, Bashir Goth, wrong choice for Somaliland&#8217;s representative in Washington DC</a></h4></div></div></li><li class="penci-feed"><div class="side-item"><div class="side-image"> <a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.somalilandpress.com/wp-content/uploads/2018/08/Dr_Mohamed_Osman_Fadal_rejected_as_NEC_Commisioner-263x175.jpg" href="https://www.somalilandpress.com/somalilandreflections-on-berbera-port-concession-agreement-in-anticipation-of-changinges-in-the-horn-africa/" title="Somaliland:Reflections on Berbera Port Concession Agreement in Anticipation of Changinges in the Horn Africa"></a></div><div class="side-item-text"><h4 class="side-title-post"><a href="https://www.somalilandpress.com/somalilandreflections-on-berbera-port-concession-agreement-in-anticipation-of-changinges-in-the-horn-africa/" rel="bookmark" title="Somaliland:Reflections on Berbera Port Concession Agreement in Anticipation of Changinges in the Horn Africa">Somaliland:Reflections on Berbera Port Concession Agreement in Anticipation of Changinges in the Horn Africa</a></h4></div></div></li><li class="penci-feed"><div class="side-item"><div class="side-image"> <a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.somalilandpress.com/wp-content/uploads/2016/07/President-Ismail-Omar-Guelleh.jpg" href="https://www.somalilandpress.com/djibouti-betrayed-and-belittled-and-then-she-is-betrayed-and-left-in-the-lurch-then-what/" title="Djibouti betrayed and belittled and then she is betrayed and left in the lurch, then what?"></a></div><div class="side-item-text"><h4 class="side-title-post"><a href="https://www.somalilandpress.com/djibouti-betrayed-and-belittled-and-then-she-is-betrayed-and-left-in-the-lurch-then-what/" rel="bookmark" title="Djibouti betrayed and belittled and then she is betrayed and left in the lurch, then what?">Djibouti betrayed and belittled and then she is betrayed and left in the lurch, then what?</a></h4></div></div></li></ul></aside><aside id="text-5" class="widget widget_text"><div class="textwidget"><p><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br /> <br /> <ins class="adsbygoogle" style="display: block;" data-ad-client="ca-pub-8106074610781145" data-ad-slot="7396301882" data-ad-format="auto"></ins><br /> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></p></div></aside><aside id="penci_latest_news_widget-2" class="widget penci_latest_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Recent Posts</span></h4><ul class="side-newsfeed penci-feed-2columns penci-2columns-feed"><li class="penci-feed"><div class="side-item"><div class="side-image"> <a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.somalilandpress.com/wp-content/uploads/2018/08/IMG_3076-263x175.jpg" href="https://www.somalilandpress.com/somalilandpresident-announces-university-graduates-will-go-on-national-service-duties-in-2019/" title="Somaliland:President Announces University Graduates Will Go On National Service Duties in 2019"></a></div><div class="side-item-text"><h4 class="side-title-post"><a href="https://www.somalilandpress.com/somalilandpresident-announces-university-graduates-will-go-on-national-service-duties-in-2019/" rel="bookmark" title="Somaliland:President Announces University Graduates Will Go On National Service Duties in 2019">Somaliland:President Announces University Graduates Will Go On National Service Duties in 2019</a></h4> <span class="side-item-meta">August 29, 2018</span></div></div></li><li class="penci-feed"><div class="side-item"><div class="side-image"> <a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.somalilandpress.com/wp-content/uploads/2018/08/Abdi-Iley_-263x175.jpg" href="https://www.somalilandpress.com/ethiopiaabdi-illey-taken-to-prison-in-the-capital-addis-ababa/" title="Ethiopia:Abdi Illey taken to prison in the capital Addis Ababa"></a></div><div class="side-item-text"><h4 class="side-title-post"><a href="https://www.somalilandpress.com/ethiopiaabdi-illey-taken-to-prison-in-the-capital-addis-ababa/" rel="bookmark" title="Ethiopia:Abdi Illey taken to prison in the capital Addis Ababa">Ethiopia:Abdi Illey taken to prison in the capital Addis Ababa</a></h4> <span class="side-item-meta">August 27, 2018</span></div></div></li><li class="penci-feed"><div class="side-item"><div class="side-image"> <a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.somalilandpress.com/wp-content/uploads/2018/08/SLDA-AWARDS-263x175.jpg" href="https://www.somalilandpress.com/the-1st-ever-somaliland-diaspora-achievement-awards-event-held/" title="The 1st ever Somaliland Diaspora Achievement Awards event Held"></a></div><div class="side-item-text"><h4 class="side-title-post"><a href="https://www.somalilandpress.com/the-1st-ever-somaliland-diaspora-achievement-awards-event-held/" rel="bookmark" title="The 1st ever Somaliland Diaspora Achievement Awards event Held">The 1st ever Somaliland Diaspora Achievement Awards event Held</a></h4> <span class="side-item-meta">August 27, 2018</span></div></div></li><li class="penci-feed"><div class="side-item"><div class="side-image"> <a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.somalilandpress.com/wp-content/uploads/2018/08/2-263x175.jpeg" href="https://www.somalilandpress.com/jama-mohamed-ismail-the-peacemaker-of-somaliland/" title="Jama Mohamed Ismail: The Peacemaker of Somaliland"></a></div><div class="side-item-text"><h4 class="side-title-post"><a href="https://www.somalilandpress.com/jama-mohamed-ismail-the-peacemaker-of-somaliland/" rel="bookmark" title="Jama Mohamed Ismail: The Peacemaker of Somaliland">Jama Mohamed Ismail: The Peacemaker of Somaliland</a></h4> <span class="side-item-meta">August 27, 2018</span></div></div></li></ul></aside><aside id="text-6" class="widget widget_text"><div class="textwidget"><p><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br /> <br /> <ins class="adsbygoogle"
 style="display:inline-block;width:336px;height:280px"
 data-ad-client="ca-pub-8106074610781145"
 data-ad-slot="9018490843"></ins><br /> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></p></div></aside><aside id="penci_facebook_widget-1" class="widget penci_facebook_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Follow Us</span></h4><div class="fb-page" data-href="https://www.facebook.com/somalilandmedia/" data-height="290" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true" data-show-posts="true"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/somalilandmedia/"><a href="https://www.facebook.com/somalilandmedia/">Facebook</a></blockquote></div></div></aside></div></div></div><div class="clear-footer"></div><div class="container penci-google-adsense penci-google-adsense-footer"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
 style="display:inline-block;width:970px;height:90px"
 data-ad-client="ca-pub-8106074610781145"
 data-ad-slot="4447237742"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div><div id="widget-area"><div class="container"><div class="footer-widget-wrapper footer-widget-style-1"><aside id="penci_about_widget-1" class="widget penci_about_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">About Somaliland Press</span></h4><div class="about-widget pc_aligncenter"></div></aside><aside id="text-4" class="widget widget_text"><div class="textwidget"><p><a href="https://www.somalilandpress.com"><img class="aligncenter wp-image-83703" src="https://www.somalilandpress.com/wp-content/uploads/2018/04/RLogo-3-new.png" alt="" width="394" height="130" /></a></p><p>News from Somaliland and the Horn of Africa</p></div></aside><aside id="penci_social_widget-1" class="widget penci_social_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Social Media</span></h4><div class="widget-social pc_alignleft show-text"> <a href="https://www.facebook.com/somalilandmedia/" target="_blank"><i class="fa fa-facebook" style="font-size: 24px"></i><span style="font-size: 16px">Facebook</span></a> <a href="https://twitter.com/somalilandpress" target="_blank"><i class="fa fa-twitter" style="font-size: 24px"></i><span style="font-size: 16px">Twitter</span></a></div></aside></div><div class="footer-widget-wrapper footer-widget-style-1"><aside id="penci_popular_news_widget-2" class="widget penci_popular_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Popular Posts</span></h4><ul class="side-newsfeed display-order-numbers"><li class="penci-feed"> <span class="order-border-number"> <span class="number-post">1</span> </span><div class="side-item"><div class="side-image"> <a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.somalilandpress.com/wp-content/uploads/2018/04/IMG_FBB847-B89C51-462610-BF8B57-F145D0-F54E2A-259x175.jpeg" href="https://www.somalilandpress.com/somalilandcentral-bank-issues-ultimatum-to-all-private-financial-institutions/" title="Somaliland:Central Bank Issues ultimatum to all Private Financial Institutions"></a></div><div class="side-item-text"><h4 class="side-title-post"><a href="https://www.somalilandpress.com/somalilandcentral-bank-issues-ultimatum-to-all-private-financial-institutions/" rel="bookmark" title="Somaliland:Central Bank Issues ultimatum to all Private Financial Institutions">Somaliland:Central Bank Issues ultimatum to all Private Financial Institutions</a></h4> <span class="side-item-meta">April 16, 2018</span></div></div></li><li class="penci-feed"> <span class="order-border-number"> <span class="number-post">2</span> </span><div class="side-item"><div class="side-image"> <a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.somalilandpress.com/wp-content/uploads/2018/04/somaliland-commonwealth-chogm-900x600-263x175.jpg" href="https://www.somalilandpress.com/somalilandwhy-we-should-be-at-the-commonwealth-summit/" title="Somaliland:Why we should be at the Commonwealth summit"></a></div><div class="side-item-text"><h4 class="side-title-post"><a href="https://www.somalilandpress.com/somalilandwhy-we-should-be-at-the-commonwealth-summit/" rel="bookmark" title="Somaliland:Why we should be at the Commonwealth summit">Somaliland:Why we should be at the Commonwealth summit</a></h4> <span class="side-item-meta">April 16, 2018</span></div></div></li><li class="penci-feed"> <span class="order-border-number"> <span class="number-post">3</span> </span><div class="side-item"><div class="side-image"> <a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.somalilandpress.com/wp-content/uploads/2018/04/15214511549131.jpg" href="https://www.somalilandpress.com/rebirth-of-somalilandthe-demise-of-the-greater-somalia-concept-and-somali-unity-notion-one-of-somalias-obsessions-part-21/" title="Rebirth of Somaliland;The demise of the Greater Somalia concept and Somali unity notion: One of Somalia’s obsessions -PART 21"></a></div><div class="side-item-text"><h4 class="side-title-post"><a href="https://www.somalilandpress.com/rebirth-of-somalilandthe-demise-of-the-greater-somalia-concept-and-somali-unity-notion-one-of-somalias-obsessions-part-21/" rel="bookmark" title="Rebirth of Somaliland;The demise of the Greater Somalia concept and Somali unity notion: One of Somalia’s obsessions -PART 21">Rebirth of Somaliland;The demise of the Greater Somalia concept and Somali unity notion: One of Somalia’s obsessions -PART 21</a></h4> <span class="side-item-meta">April 10, 2018</span></div></div></li></ul></aside></div><div class="footer-widget-wrapper footer-widget-style-1 last"><aside id="penci_latest_news_widget-3" class="widget penci_latest_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Editor&#8217;s Picks</span></h4><ul class="side-newsfeed"><li class="penci-feed"><div class="side-item"><div class="side-image"> <a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.somalilandpress.com/wp-content/uploads/2018/08/IMG_3076-263x175.jpg" href="https://www.somalilandpress.com/somalilandpresident-announces-university-graduates-will-go-on-national-service-duties-in-2019/" title="Somaliland:President Announces University Graduates Will Go On National Service Duties in 2019"></a></div><div class="side-item-text"><h4 class="side-title-post"><a href="https://www.somalilandpress.com/somalilandpresident-announces-university-graduates-will-go-on-national-service-duties-in-2019/" rel="bookmark" title="Somaliland:President Announces University Graduates Will Go On National Service Duties in 2019">Somaliland:President Announces University Graduates Will Go On National Service Duties in 2019</a></h4> <span class="side-item-meta">August 29, 2018</span></div></div></li><li class="penci-feed"><div class="side-item"><div class="side-image"> <a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.somalilandpress.com/wp-content/uploads/2018/08/Abdi-Iley_-263x175.jpg" href="https://www.somalilandpress.com/ethiopiaabdi-illey-taken-to-prison-in-the-capital-addis-ababa/" title="Ethiopia:Abdi Illey taken to prison in the capital Addis Ababa"></a></div><div class="side-item-text"><h4 class="side-title-post"><a href="https://www.somalilandpress.com/ethiopiaabdi-illey-taken-to-prison-in-the-capital-addis-ababa/" rel="bookmark" title="Ethiopia:Abdi Illey taken to prison in the capital Addis Ababa">Ethiopia:Abdi Illey taken to prison in the capital Addis Ababa</a></h4> <span class="side-item-meta">August 27, 2018</span></div></div></li><li class="penci-feed"><div class="side-item"><div class="side-image"> <a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="https://www.somalilandpress.com/wp-content/uploads/2018/08/SLDA-AWARDS-263x175.jpg" href="https://www.somalilandpress.com/the-1st-ever-somaliland-diaspora-achievement-awards-event-held/" title="The 1st ever Somaliland Diaspora Achievement Awards event Held"></a></div><div class="side-item-text"><h4 class="side-title-post"><a href="https://www.somalilandpress.com/the-1st-ever-somaliland-diaspora-achievement-awards-event-held/" rel="bookmark" title="The 1st ever Somaliland Diaspora Achievement Awards event Held">The 1st ever Somaliland Diaspora Achievement Awards event Held</a></h4> <span class="side-item-meta">August 27, 2018</span></div></div></li></ul></aside></div></div></div><footer id="footer-section" class="penci-footer-social-media penci-lazy footer-social-remove-circle"><div class="container"><div class="footer-logo-copyright footer-not-logo footer-not-gotop"><div id="footer-copyright"><p><p class="copyright-info"> @2018 - <a href="https://www.somalilandpress.com/">Somaliland Press</a>. All Right Reserved.</p><p class="copyright-info-mansur"> Developed by <a href="https://www.mansuralam.com/" target="_blank">Mansur Alam</a></p></p></div></div><div class="penci-go-to-top-floating"><i class="fa fa-angle-up"></i></div></div></footer></div><div id="fb-root"></div> <script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"https:\/\/www.somalilandpress.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};</script> <script type='text/javascript'>var ajax_var = {"url":"https:\/\/www.somalilandpress.com\/wp-admin\/admin-ajax.php","nonce":"47d639bca0"};</script> <script type='text/javascript'>var ajax_var_more = {"url":"https:\/\/www.somalilandpress.com\/wp-admin\/admin-ajax.php","nonce":"47d639bca0"};</script> <p class="copyright-info-mansur-backlink"> Developed by <a href="https://www.mansuralam.com/">Mansur Alam</a></p>  <script type="text/javascript" defer src="https://www.somalilandpress.com/wp-content/cache/autoptimize/js/autoptimize_df23e625f8081561b15d4957a5a93c6f.js"></script></body></html>